NASトラブル なぜか復旧した

スポンサーリンク
スポンサーリンク

NASが突然異常状態となりました。

以前は常時使っていましたが、最近では週に何回か数時間使うという程度。

ミラーリングのraid1で使っていたのですが、ある時起動してアクセスすると、異常であるというようなメッセージが表示されました。

NASのコントロールパネルからraidの状態を見ると、degradedとなっている。

調べてみると、異常であることは間違いない。

どうやらHDDの片側が故障しており、片側だけで動いているみたい。

普通のHDDに成り下がってしました。

データにアクセスしても普通なのでとりあえずは問題ないのですが、今普通に動いているHDDが故障したらデータは全て消えるってことですね。

怖すぎる。

でも、ここで少し考えました。

使用状況からHDDの使用時間を考えると、あまり故障は考えられないような気がします。

ならどういうことか?

NAS自体が故障して、誤って片側のHDDが異常と表示してしまっている可能性のほうが高いのでは?

HDDかNAS自体か、どちらが壊れているかを確認せずに対応するのは難しそうです。

一番簡単なのは、新たにHDDを購入して、壊れているほうのHDDと入れ替えること。

でも、もしNAS自体が壊れていた場合、購入したHDDは特に使い道も無いため、完全な無駄となります。

今ちょっとお金にあまり余裕が無くて、無駄な買い物はしたくありません。

しかも、NASは壊れているということなので、NASを購入しないといけません。

NAS+HDDの購入となって痛すぎます。

なら、とりあえずHDDが壊れていない、ということを確認してみるしかない。

考えたのですが、NASからHDDを外して、他のPCに入れるなり、外付けHDDケースに入れて確認するしかなさそうです。

ただ、PCにつなぐのは、スロットがすべて埋まっていたため、現状ちょっと面倒。

HDDケースを持っていないので購入するしかありません。

安いのものを物色。

Logitec HDDケース 3.5インチ USB3.1(Gen1) / USB3.0 ハードディスク ケース LHR-EKWU3BK[macOS Big Sur 11.0 対応確認済]

約2000円。

これくらいの負担なら耐えられますし、余っているHDDで後々使うこともあるかもしれない。

ということで購入。

購入後、HDDを外すのがなんとなく怖いので、NASから他のPCなどにデータをバックアップしたい。

まず、この段階でかなり面倒でした。

5TBくらいのデータ容量があって、バックアップのデータを除くと、4TB弱くらい。

まずは、2台のPCの空き容量に分散してコピー。

それでも足りないので、さらに余っていた2台の外付けにコピー。

それでもまだちょっと足りず、もう一台のNASにコピー。

これで何とかすべてのデータがバックアップできたので、もし誤ってすべてのデータが消えても大丈夫。

ここまでで3日程かかってしまった。

NASからHDDを抜いてケースに入れる。

それをPCに接続すると、ドライブの管理を見ると、どうもHDD自体は認識しているみたいだし、フォーマットもできそう。

この状態だと、HDDは生きているかもしれない。

NASに刺さっていた時は、raidを復旧もできないし、そもそもHDDを認識していないような状態でした。

でも、ケースに入れたらPCが普通に認識していることからHDDは壊れていないっぽい。

ならNASが壊れてるってことだ。

NAS買うしかないのかな?

ちょっと探してみたけど、NASを買うのは厳しすぎ。

このあたりにしようと思ったけど、高いね。

【NASキット】Synology DiskStation DS220+ [2ベイ / デュアルコアCPU搭載 / 2GBメモリ搭載] 国内正規品+電話サポート対応品

今のNASもメモリーは2GBだったからこれを選びました。

今のよりも性能が下がるのは気になるからなあ。

買うしかないか、と思いながら、その前に最後の悪あがき。

もう一回外付けケースからHDDを外してNASに刺し、コントロールパネルにアクセスしてみました。

!!!

なぜかHDDを普通に認識しています。

復旧も選択できる。

データはすでにすべてバックアップとしてどこかにコピーがある状態なので、恐る恐る復旧させてみた。

すごく遅いけど、復旧をはじめました。

ついてる!

復旧をはじめましたが、ここから時間がかかりました。

はじめは100%復旧するまでの時間を計算すると2日くらいだったのですが、NASも疲れてしまうのか?最終的に完了したのは2.5日後。

半日遅れとなりましたが、無事に、復旧完了となりました。

その後はというと、今のところ、普通に動作しています。

もしかすると、年末の大掃除の時に動かしたりしたので、何か接触不良でもあったのかもしれません。

最初から、抜き差ししてもう一度確認をしたらよかったかもしれません。

いつ使うかわからない外付けのケースだけが残ってしまった。

まあ、出費がそれくらいで済んだので良しとします。

コメント

タイトルとURLをコピーしました